Bookmarks not appearing in dropdown for new analysis

we’re on 2.4 (beta) and have seen a few instances where we’ve created a new bookmark to test with and then go to QSDA and start a new analysis (using the new Open > New Analysis workflow) but the new bookmarks don’t appear in the dropdown. We’ve tried re-selecting the app, clicking the refresh above the bookmark dropdown, etc and it’s just not there initially. Seems to either show up eventually, or we’ve found that duplicating the app means it will show up (sometimes?), but we kind of just have to keep checking or duplicating until it shows up. Are we missing something that will help those propagate?

I’m assuming your scenario is:

  1. You open and maybe analyze an app in QSDA.
    2, You open the same app in the hub and add a bookmark.
  2. You return to QSDA and refresh the bookmarks, and the new bookmark isn’t there,

I’ve noted that Qlik Sense can be slow to propagate changes made in one session to all other users (QSDA). This is particularly true with bookmarks. What seems to help is to make sure you close the browser tab where you made the change. I haven’t found a fixed time, but it seems to show up in max of 15 minutes or so.


Thanks, Rob. I don’t know that the process is always that linear, but yeah, something along those lines. We have an app we’re trying various things to improve performance and so are trying to run multiple analyses to assess the improvement (one of the reasons we’re really glad to have QSDA!). I think the most reliable way we’ve found is to duplicate the apps and then add the bookmarks, which seems to work reasonably well, which is probably in alignment with what you noted above, it just means we’ll have to remember to cleanup the duplicate copies. I’ll make a point to close tabs and see if that improves things (close tab or close entire session? would incognito be better?) If we happened to log in with the QSDA user to create them, you think they’d show up faster?

What connection type are you using?

Closing the tab that has the app open should be enough. Logging in with the QSDA user is an interesting idea. Let me know if that makes a difference.

I found that changing the connection user to my user did mean the bookmarks showed up right away, and incidentally made our QSDA environment noticeably faster. We currently use a system user via Certificate connection with SR environment of qmc so that everyone can access their own apps via one connection (we use an internal SAML SSO in our Qlik environment that I don’t believe we can use with QSDA (is that correct?)) and our environment is pretty large, so the app list is pretty slow.

So, changing the connection to my user temporarily did work, but I think I was then running into caching issues that meant I wasn’t getting a real app load time, so I ended up changing the connection a handful of times. It was a bit of a hassle, but did get there in the end and the data I think was enough to get buy in from our business teams to make some needed changes to the app, which is a win.

If you have any recommended setup changes, happy to hear them.

we use an internal SAML SSO in our Qlik environment

Have you tried the QLIKLOGIN connection type?