EasyQlik Community

Build 0.2.0 is available

A new build, 0.2.0, is available. A new startup Control Panel and a lot of internal changes. See a summary of the changes here What's New in V0.2.0 Alpha

If you want to install locally to test with your own apps, download the latest build here https://easyqlik.com/dmgr/?file=Qsda_Pro_Setup_020.zip

If you want to take it for a spin on the demo site:
http://easyqlik.com/qsda/demo

Hi Rob,

I have finally found the time to play around again with this against QSD. First, small sized app with relatively tidy data model, which worked really well.

Then I tried two of our messy applications with lot of comments and medium sized complexity in data model. However, both apps seem to have failed at the parsing phrase right at the end. I haven’t taken a detailed look at the error logs, but at a quick glace, it looks like long expressions with comments and lots of variables might have been the culprits. I am attaching the error logs, that might help. Let me know if you need the apps with no data, I can try to strip them of data and see if we can share them to help with your development.

PS: Cant attached log files in here. This is the link to the dropbox

Kab

I don’t think the parsing is the culprit, it’s another issue. I have another tester reporting a similar null pointer exception. I can’t seem to recreate so would very much like to have a copy of the app without data or obfuscated data.

Hi Kab,
0.2.2 fixes the QCS connection. I’ve also added quite a bit of diagnostic logging to help pin down errors. Can you try analyzing your big app again and if fails post the log/qsda-YYYY-MM-DD.log?

1 Like

hmm getting new issue with the new built, I removed the old version and deleted the installation folders etc, cleared the browser cache too. Then proceeded with the installation of the new version. And now I can’t save my connection details. The buttons are disabled, I am putting the same information as yesterday. Both buttons are disabled for all options.

PS: I changed the host name there to something generic for the screen shot.

Well I messed that up! Sorry, fixed in this 0.2.3 build. https://easyqlik.com/dmgr/?file=Qsda_Pro_Setup_023.zip

1 Like

ok will give it a try now. Thanks

Still getting the error, here is the log

I will check with work to make sure they are ok with me sharing the app as its not an internal application. Meanwhile I will run it against some internal app tomorrow morning.

Regards
Kab

Hi Kab,
Thanks for the log. If you still have patience, can you try it with this 0.3.0 build https://easyqlik.com/dmgr/?file=Qsda_Pro_Setup_030.zip

That should catch the problem as a soft error so I can identify the cause. Still happy to take a copy of the app if that’s possible.

Thanks,
Rob

Sorry, I didn’t get time to do this. I will do it later today if that’s ok.

Hi,

I found some time in between meetings, so quickly installed it. Good news, it worked with only 2 errors this time. I haven’t taken a look at the errors, I think it’s the expression used in the variable is wrong, not QSDA issue. But I have uploaded the logs so you can take a look.

Log files

Kab

Thanks! This is useful.

What I can’t tell from the logs is if the remaining viz expressions were parsed or the expression processing stopped there. it looks like it may have stopped prematurely. If you looks at the fields page, do all expressions show Fields and Variables values?