EasyQlik Community

No connection to UI after installation

I have installed QSDA 1.2.2-Beta on the server where Qlik Sense is installed. I have used the same account as Qlik Sense is running on. When I try to access http://localhost:5003 I get an Http
QSDA_20210610.zip (22.6 KB)
Error 500.

I have tried to restart the services several times without any luck. I attach the logfiles and hope that you can help me to find the problem. I have turned on debug logging.

Br,
Thomas

Hi Thomas,
Is this server on premise, Azure or some other cloud hosting service?

Hi Rob,
This is a virtual server on prem. I thinkt they are using VMVare (but not 100% sure).

The logged error is related to a problem with the data protection key. The key is used to encrypt any sensitive information you enter in the connection. Can you take a look at
C:\Users\userid\AppData\Local\ASP.NET\DataProtection-Keys
(where userid is the user that started QSDA)
and see if there are any xml files there? If so, what are their sizes?

Hi,
Problem solved.
There where 4 files in the folder, 3 with size 2 KB and one with 0 KB… All of the where old, from 2018.
I removed them and reinstalled the program and now it works.

However I run into another problem regarding manage the connection. The customer that I test QDSA has many developers that should use QDSA. They could work from their own PC or from a common server (via Remote Desktop). I have installed QDSA on the Qlik Sense server. Which connection type should I use? I have tried with WINDOWS, but that didn’t work. I seems like the service account don’t have access (I get 403 error). The service account is Root Admin and have a license.
When I swithched to NTML and add my own account I can analyze my own applications, but as I understand the configuration i global.
Please advice me how to do.
Br, Thomas

The QSDA Control Panel is currently a desktop app. So when using the WINDOWS connection the connection will use whatever userid started the control panel.

For a shared server setup, the recommended connection type is CERTIFICATE. You will need to select a userid to impersonate, a userid with proper permissions in Qlik Sense. You can also do the same thing using the NTLM connection, just pick a shared id like “qsda”.