QSDA V2 Beta is Available

I’m pleased to announce the availability of QSDA Pro V2 Beta release. If you want to give it a try, you can download it using this link.

Upgrade notes and a summary of what’s new can be found here:

Here are some highlights of this release.

  • Multiple Connections!

  • You can select a defined connection on the App List page.


  • New tiles show Collections in the Repo, in process, and ready. For all and the current connection.


  • The QLIKLOGIN connection experience is much much smoother. Particularly if QSDA is installed on the Qlik Server.

  • You can limit how many Collectors run concurrently.

  • If you have a QSDA Pro Enterprise license, you can optionally authorize access to QSDA using Windows groups.

You can leave feedback, questions or problems here. If you have something private you need to share use the support site or the contact form.

Thanks for testing!

Hi Rob,

After upgrade to v2, the data connection parameters got lost, it’s ok.

I have used the very same input parameters to define a data connection over a certificate.
It was working on v1.8, but fails in V2 beta with the following error message:

“Unable to establish websocket connection. Unable to connect to the remote server The SSL connection could not be established, see inner exception. The remote certificate is invalid according to the validation procedure: RemoteCertificateNameMismatch, RemoteCertificateChainErrors”

Over a Windows connection type:
“Websocket closed unexpectedly (EndpointUnavailable):”

If that helps, I see the below entry in the error logs:
2022-06-07 16:50:04.6076 Microsoft.AspNetCore.Components.Server.Circuits.CircuitHost.ReportUnhandledException Error Unhandled exception in circuit ‘ZncRLSDsMTbxhw7LdT7PocJHwq-O1NYLsb29lMd9YZY’. Microsoft.JSInterop.JSException: Failed to fetch dynamically imported module: http://FULLSERVERNAME:8443/_content/Syncfusion.Blazor/scripts/syncfusion-blazor-28e68d.min.js
TypeError: Failed to fetch dynamically imported module: http://FULLSERVERNAME:8443/_content/Syncfusion.Blazor/scripts/syncfusion-blazor-28e68d.min.js
at Microsoft.JSInterop.JSRuntime.InvokeAsync[TValue](Int64 targetInstanceId, String identifier, Object[] args)
at Microsoft.JSInterop.JSRuntimeExtensions.InvokeVoidAsync(IJSRuntime jsRuntime, String identifier, Object[] args)
at Syncfusion.Blazor.Internal.SfBaseUtils.ImportModule(IJSRuntime jsRuntime, SfScriptModules scriptModule, String hashKey)
at Syncfusion.Blazor.SfBaseComponent.OnAfterRenderAsync(Boolean firstRender)
at Microsoft.AspNetCore.Components.RenderTree.Renderer.GetErrorHandledTask(Task taskToHandle, ComponentState owningComponentState)

Can you please post a screenshot of your connection settings? If you would prefer to not share publicly, please submit via the support forum or a contact form.

Also, do you have “Use HTTPS” enabled?

A fix for your certificate issue is in the 2.0.1 beta

1 Like

Thanks Rob, the fix works.
There is still an issue with the login connection, I’ll use the support forum.

No, HTTPS is not enabled (yet)